
Context for Importing Content from Word into Madcap Flare 
Tutorial 

Background 

Because creating content into Flare takes a lot of time, transferring content from one tool to 

another is faster when that content already exists in another authoring tool. A few situations 

occurred at ABB where the technical writers needed content from Microsoft Word into the 

content creation and publishing tool, Madcap Flare. Because of my experience with authoring 

tools and the ability to export and import content (e.g. FrameMaker content into Flare), I felt that 

there had to be a better and faster way to create guides in Flare that were previously authored 

in Word besides manually creating topics and copying and pasting content from Word into Flare. 

 

➢ Audience: Technical writers who needed a more productive or faster way to transfer 

content into Madcap Flare. 

➢ Percentage of I wrote: 100%. 

➢ Original content or revised content: The document is my original writing. 

➢ Resources for drafting content: The content derived from my experience using Flare, 

experimenting with some options in Flare, and research conducted for importing content 

from Word into Flare. Madcap’s website was helpful in understanding how to import content 

into Flare: https://help.madcapsoftware.com/flare2024/Content/Flare/Importing/Other-

Applications-Files/Word/Importing-Word-Files.htm  

➢ Content editing: I edited the document myself as someone confident in my editing abilities 

because of my background. The document underwent moderate editing.  

➢ Style guide usage: A company style guide was not used to write this document. I used a 

template that I created for the format and used the Microsoft Manual of Style for user 

interface text. The template is a good template for content that will be published as a pdf or 

Word document. When a style guide is not applicable, I create a style sheet when needed to 

ensure consistency within a document. 

➢ I created this document in my personal time to help me import content into Flare after seeing 

much content on Madcap’s website that wasn’t needed for someone with my knowledge of 

Flare or my specific use case. I decided to share it with my co-workers at ABB after realizing 

that it would help them. I changed generic information to team-specific details for the copy I 

shared with my team. I maintained my own template because no templates existed for 

general Word documents, except for release notes. 

https://help.madcapsoftware.com/flare2024/Content/Flare/Importing/Other-Applications-Files/Word/Importing-Word-Files.htm
https://help.madcapsoftware.com/flare2024/Content/Flare/Importing/Other-Applications-Files/Word/Importing-Word-Files.htm


➢ Additional useful context, such as deadlines, achievements, etc.: There were no 

deadlines for this tutorial. It was a project that I took the initiative to do as guidance for 

myself. It was helpful for a co-worker who only used Word and was required to start using 

Flare for her product guides. My manager at that time also worked on guides in Word and 

Flare and used the tutorial to import Word content into Flare. I trained both in how to use 

Flare. 

➢ Changes after publication and why? I edited the document by adding the following 

sections: Introduction, Prerequisites, and Audience. For better organization and help users 

find sections easier, I added headings. I also made the content more concise and performed 

some copyediting. 

My Process 

I performed research to discover if there was a method for converting a Word file into a Flare 

file. There wasn’t a way of converting the file type like with FrameMaker. However, I found a 

method for exporting content from Word and importing that content into Flare on the Madcap 

website. While attempting to follow the steps, I realized that some steps were missing, there 

was too much unnecessary information for my use case, and the steps were not as clear as 

they could be.  

 

To create clear and concise guidance, I needed to create instructions for writers who already 

knew how to use Flare at a certain level and knew what to do once the content was imported in. 

The Madcap Flare guidance included information that the intermediate and advanced Flare 

users at ABB did not need. Also, the content was not as clear as it could have been. I had a 

hard time filtering out content that was more noisy than helpful. Because I was the user and 

performing the steps was a way to usability test the documentation, I was able to recognize the 

gaps in the information and what information was not needed for the audience’s knowledge 

level. I revised the information and created the steps provided in the tutorial. 

How I Went Above and Beyond 

Because of the quality of work that I believe in delivering, I went beyond what was required in 

the following ways:  

➢ created an aesthetically-pleasing template for the tutorial that enhanced readability. 



➢ Created note and example boxes to ensure that numbered items consisted of only action 

steps (besides the headings) and users could easily recognize steps from additional 

information. 

➢ Ensured headings are numbered so users can easily reference sections. 

 



Importing Content from Word 
into Madcap Flare 

1 Introduction 
Madcap Flare is a single-source authoring tool that can receive content from other file 
types through the Import feature. This function is beneficial as it helps authors save 
time through a quicker transporting method versus copying and pasting between tools.  

The focus of this tutorial is importing content from Microsoft Word into Madcap Flare. 
This is helpful when content exists in Word, but you are transitioning into single-source 
authoring. When wanting to transfer content from a Word document into a Flare 
project, creating individual topics, copying and pasting the content into Flare, and 
applying styles to the content in Flare would take longer than importing the content 
into Flare.  

1.1 Prerequisites 

A licensed version of Madcap Flare and Microsoft Word on your computer is required 
to follow this tutorial. This tutorial is for importing content into Flare projects with an 
existing stylesheet and Flare project template.  

1.2 Audience 

This tutorial is for writers and SMEs who have intermediate to advanced knowledge of 
Flare. Some beginners can use this tutorial when knowing how to complete common 
tasks, such as creating topics, creating a table of contents, rectifying build errors, and 
performing any cleanup steps after importing content.  

2 The Import Process 
To save time or increase productivity, import content into Flare from Word by 
completing the following steps. 

Note: 

You can use an existing Flare project with the style sheet and setup 
versus starting a new project (for example, make a copy of an old install 
guide and rename it to import new install guide content into the Flare 
project). 

2.1 Preparing the Word Document for Import 

1. Open the Word document, and ensure that no inline formatting exists in the 
document. 

2. Ensure heading, paragraph, and character styles are assigned to content. 
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Note: 
Assigning styles to content is important for mapping Word styles to 
Flare styles later. If styles are not assigned to the Word content, more 
cleanup will need to happen in the Flare project later. 

 

3. Create private field codes in headings that you want as individual files.  

4. Place your cursor on a heading where you want to start a new topic in Flare. 

a. Select Insert > Quick Parts > Field. 

 

Note: The Field dialog opens. 

 

b. In the Field name section, scroll down and select Private. 

c. In the Field codes section, enter the following code with custom file name as 
the file name for your new topic:  

PRIVATE:MADCAP:FILENAME:<custom file name> 

Example: 

There is a heading in a Word document that uses the Heading 
1 style and contains the text All about rabbits. You want a new 
topic to be created at that point when you import the 
document. However, you also want to make sure that the file 
name for that new topic is rabbits. Therefore, you open the 
Word document and apply a private field on that heading, 
using the following format with rabbits as the custom file 
name: 

PRIVATE:MADCAP:FILENAME:rabbits 

 

5. When you import the word document, select Split new topics on certain styles, 
selecting the Heading 1 style.  

Note: 
After the import is finished, one of the topics or file names created is 
rabbits.htm. 

 

6. Click OK. 

7. If you want to view the field codes in the Word file, press Alt+F9 for a shortcut 
option, or perform the following steps: 

a. Click the File tab, and click Options. 

b. Click the Advanced tab, and check Show field codes instead of their 
values. 
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c. Uncheck Show field codes instead of their values before saving the Word 
file. 

Note: 
Not unchecking Show field codes instead of their values will 
result in an error message when importing the Word file into Flare 
(error message shown in following image). 

 

 
 

d. If you don’t want the heading numbering from Word imported into the Flare 
project, remove the numbering from the headings in the Word file before the 
import.  

e. Remove any front matter (title page, copyright page, etc.) that you don’t want 
in Flare before the import. 

f. Save the Word document. 

2.2 Preparing the Flare Project for Import  

1. Open the Flare project being used as the base project. 

2. Ensure that your stylesheet is the default stylesheet for the project by selecting 
Project > Project Properties > Defaults > stylesheet.css from the Master 
Stylesheet dropdown menu with stylesheet being the name of your stylesheet. 

Note: 
If your stylesheet file name is flare_base.css, the navigation would be 
Project > Project Properties > Defaults > flare_base.css. 

 

3. Ensure other sections in the Defaults tab are correct too.  

a. If the master TOC/target will be HTML5 (or other online help output), set the 
defaults based on this output.  

b. Add whatever targets and TOCs needed to accompany this master output. 

2.3 Importing the Content into Flare 
 

1. Import the Word document into the Flare project by selecting Project > Import > 
MS Word Documents. 

2. Select Import into this project if the base project is an existing project. If not 
select Import into a new project.  

3. When the wizard pops up, add the Word file by clicking on the Add icon  and 
selecting the Word file from wherever it is saved.  
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4. Uncheck the Link Generated Files to Source Files checkbox if checked and click 
Next. 

Note: 
Once the scanning starts, it may get stuck. There may be a prompt to 
convert the template above the scanning window.  

 

5. If there is a prompt to convert template, click No for conversion.  

Note: The file should import in. 

 

6. On the New Topic Styles dialog, select the style(s) where you inserted private 
fields in the Word document. 

Example: 

An example is Heading 2 in the Word file, which all new Flare files 
will start with because the heading 2 style is used for new topics 
(topics are files in Flare). A new file name will occur wherever the 
Heading 2 style exists. 

 

7. Click Next. 

8. In the Options dialog, select 40 characters for the Approximate Filename Length 
option as a substantial length and click Next. 

Note: Filenames can be changed later as needed. 

 

9. In the Stylesheet dialog, associate your stylesheet to the project. 

 

10. Select Don’t Preserve FrameMaker Styles and click Next. 

11. Map styles from the Word document to the styles in Flare: 

Note: 
Your Word style will adopt the name of that style. Mapping character 
styles works the same as the feature for mapping paragraph styles, 
except it has to do with character-level styles. 

 

a. Click the style in the MS Word Style column, and click a style in the Flare 
Styles section.  

b. Click Map. 

Note: 

The style is added to the Flare Styles column. When you are 
finished importing the documents and the new Flare project is 
loaded, the content associated with the style in the Word 
document will now be associated with the Flare style that you 
mapped it to.  

For example, the Heading 2 style in the Word file will be mapped 
to the h2.heading2 style in Flare. 

 

12. Perform one of the following, depending on the part of the interface you are using: 

a. Wizard: Click Finish.  
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Note: 
The Accept Imported Documents dialog opens. The files that will 
be created because of the import are listed on the left. A preview 
of each file can be seen to the right when you click the file. 

 

-OR- 

b. Import Editor: In the local toolbar, click Import (if this is the first time importing 
files) or Reimport (if files have been imported previously).  

Note: 
The Accept Imported Documents dialog opens. The files that will 
be created because of the import are listed on the left. A preview 
of each file can be seen to the right when you click the file. 

 

13. When you are done previewing the files to be created, click Accept. 

2.4 Cleaning up the Flare Project 

1. If the files have a U.S. flag at the top before the first heading, do a Find All and 
Replace All for xml:lang="en-us"  

a. Perform the Find All with a space before the tag (xml:lang=”en-us”). 

b. Check one file in the text editor to see if a space is needed after the tag.  

c. Replace the text with a backspace by pressing the Backspace key once in the 
Replace box.  

d. If an error message pops up, ignore it if the text is replaced.  

2. If any other flags exist, do the same as with the U.S flag but replace en_us in 
xml:lang="en-us" with another country or letters. 

3. Perform any necessary cleanup by ensuring any imported stylesheets are 
replaced with your stylesheet and remove any imported stylesheets from the 
project.  

4. Go to Content > Resources > Stylesheets to view any imported stylesheets.  

Note: Only your stylesheet and any overriding stylesheets should exist. 

 

5. Ensure the first heading for each file has the appropriate heading style name from 
your Flare stylesheet and not the Word style name. 

6. Ensure all text and tables within files have the desired styles by making any 
necessary changes.  

Note: 
A Find and Replace in the project during cleanup will help with 
replacing styles faster. 

 

7. Manually remove any bookmarks in each file. 


